Unable to Login/Latency

Incident Report for Convoso

Resolved

The issue is resolved and full service is restored. We will issue a RFO to reporting clients in due course. We would like to take the opportunity to apologize for the disruption to your operations.
Posted Sep 02, 2026 - 07:17 PDT

Monitoring

The issue has been identified as an external network connectivity event, and we are working with our partners to restore full functionality.
Posted Sep 02, 2026 - 07:04 PDT

Investigating

We have received multiple reports of the inability to reach and login to the Admin Dashboard and the Agent Console. We are investigating this as a top-priority issue.
Posted Sep 02, 2026 - 07:02 PDT
This incident affected: Agent Interface (Dialer).