AWS Route 53 Degraded Performance

Incident Report for Convoso

Resolved

At this time Amazon has indicated issues with AWS Route 53 are resolved. Convoso did not see impacts from this external issue.
Posted Mar 02, 2026 - 16:12 PST

Monitoring

We are closely monitoring reports of Degraded Performance with Amazon AWS Route 53 services. At this time we are not seeing any impacts to the Convoso platform.
Posted Mar 02, 2026 - 08:50 PST
This incident affected: Infrastructure (AWS route53).