Customers may experience delays placing calls

Incident Report for Convoso

Resolved

This issue is now resolved. We appreciate your patience as we worked urgently to address this issue. We apologize for any impact it may have had on your operations.

Customers who reported impact will receive an RFO as soon as possible.
Posted Feb 05, 2025 - 07:29 PST

Monitoring

A fix has been implemented and we are closely monitoring to verify full resolution.
Posted Feb 05, 2025 - 07:11 PST

Identified

The issue has been identified and our team is actively taking mitigation steps to reduce impact for our customers.
Posted Feb 05, 2025 - 06:43 PST

Investigating

We have identified an issue that may result in delays or slower dialing for our customers. We are working urgently to resolve this.
Posted Feb 05, 2025 - 06:37 PST
This incident affected: Agent Interface (Dialer).