Users may experience trouble accessing Convoso

Incident Report for Convoso

Resolved

As of 7:05 AM PST this issue has been resolved. We appreciate your patience as we worked to address this issue. We apologize for any impact this may have had on your operations, and customers who reported impact will receive an RFO once available.
Posted Apr 24, 2025 - 07:09 PDT

Monitoring

A fix has been implemented and we are closely monitoring for any persisting impact at this time.
Posted Apr 24, 2025 - 06:50 PDT

Investigating

Users may be experiencing trouble connecting to agent.convoso.com at this time. We are urgently working to resolve this issue.
Posted Apr 24, 2025 - 06:32 PDT
This incident affected: Agent Interface (Dialer, Scripts) and Admin Interface (Campaigns and Hopper, API, Workflow Automation, Leads, Reports and Dashboards).